๐Ÿ”ฎ Sanity Create is here. Writing is reinvented. Try now, no developer setup

Error when running 'npm run graphql-deploy' in sanity-gatsby-portfolio-studio

9 replies
Last updated: Jul 21, 2020
Hi there! I'm just starting out with the sanity-gatsby-portfolio. I made some edits to the studios schema and everything showed up fine in the studio on development, but when I run 'npm run graphql-deploy' to restart the graphql server I get the error :

lerna ERR! npm run graphql-deploy exited 1 in 'sanity-gatsby-portfolio-studio'

npm ERR! code ELIFECYCLE

npm ERR! errno 1

npm ERR! sanity-gatsby-portfolio@0.0.0 graphql-deploy: lerna run graphql-deploy

npm ERR! Exit status 1

npm ERR!

npm ERR! Failed at the sanity-gatsby-portfolio@0.0.0 graphql-deploy script.

npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

Can anyone help me with this please?
๐Ÿ™‚
Jul 21, 2020, 2:25 AM
you're trying to re deploy your changes to the Sanity schema? You need to run
sanity graphql deploy
on the studio folder
Jul 21, 2020, 2:29 AM
Hi Lucho
Jul 21, 2020, 2:30 AM
Yes, that's what I'm trying to do - Just tried that and got this error
Jul 21, 2020, 2:30 AM
Dataset: production

Tag: default


โ ™ Checking for deployed API

Error: Request returned HTTP 401
Jul 21, 2020, 2:30 AM
oh! I think I just had to log in... duh
Jul 21, 2020, 2:40 AM
yes. Did it work after you logged in?
Jul 21, 2020, 2:44 AM
thanks for replying!
Jul 21, 2020, 2:44 AM
yes!
Jul 21, 2020, 2:44 AM
๐Ÿ‘
Jul 21, 2020, 2:44 AM

Sanityโ€“ build remarkable experiences at scale

Sanity is a modern headless CMS that treats content as data to power your digital business. Free to get started, and pay-as-you-go on all plans.

Was this answer helpful?