v0.142.4

Released Sep 4th 2019

Upgrade the Command Line Interface (CLI) with

npm install --global @sanity/cli

Upgrade the Content Studio with:

sanity upgrade

Deprecating support for React < 16.8

Today the minimum version of React required by the Content Studio is 16.3. This means the developer team at Sanity must be careful about using new features introduced in React after v16.3.

The most notable thing we're missing is the ability to use React Hooks. So today we're deprecating versions prior to React 16.8, and soon we will start ship new versions of the sanity studio that relies on features introduced after 16.3 up to and including 16.8.

If you are using an old version of React in your studio, you will now see a deprecation warning telling you to upgrade the versions of react and react-dom. You can read more about upgrading the packages required by the Sanity studio here

Note: This should not cause any trouble as there's no breaking changes between React 16.3 and 16.8, but if you run into any problems, please drop by our community slack and let us know.

📓 Full changelog

AuthorMessageCommit
Bjørge Næsscore Deprecate react < 16.8 (#1474)09decba02