✨Discover storytelling in the AI age with Pixar's Matthew Luhn at Sanity Connect, May 8th—register now

Issue with deploying Sanity Studio and the solution involving logging in with `sanity login`.

3 replies
Last updated: Aug 17, 2023
👋 Hello, team! I am not able to deploy sanity studio for my project.
I have tried executing
yarn sanity deploy
and after answering a couple of questions it fails saying
User is missing required grant sanity.project/update to perform this operation
I have tried with admin and deploy tokens, both in
.env
file and actual environment variable.
Any ideas?
Aug 17, 2023, 9:24 AM
Could you take a look at the solution in this thread to see if it works for you? Thanks.
Aug 17, 2023, 10:46 AM
Will do. Thanks
Aug 17, 2023, 11:03 AM
Found the problem. It seems for the very first deployment I need to be logged using
sanity login
. After that the deploy token works properly.
Aug 17, 2023, 12:33 PM

Sanity– build remarkable experiences at scale

Sanity is a modern headless CMS that treats content as data to power your digital business. Free to get started, and pay-as-you-go on all plans.

Was this answer helpful?