Join our next Developer Virtual Meetup – Live Q&A, Project Showcase, Swag raffle, and more 🔥

Issue with compiling Sanity after updating Mac OS, resolved by upgrading Studio version.

7 replies
Last updated: Nov 23, 2022
Hi all! I regrettably updated my Mac OS from 12.6 to 13 yesterday, which seems to have impacted my Sanity dev environment. Now, when compiling Sanity errors out with the information below. Has anyone else run into this and if so how did you resolve? Thanks in advance!

✔ Compiling...
Failed to compile.

Error in ./node_modules/@floating-ui/dom/dist/floating-ui.dom.esm.js
Module parse failed: Unexpected token (313:11)
You may need an appropriate loader to handle this file type.
|   }
| 
|   return { ...rect,
|     x: rect.x - scroll.scrollLeft + offsets.x,
|     y: rect.y - scroll.scrollTop + offsets.y
 @ ./node_modules/sanity-plugin-order-documents/node_modules/react-select/dist/react-select.esm.js 24:0-26
 @ ./node_modules/sanity-plugin-order-documents/build/components/organisms/TypeSection.js
 @ ./node_modules/sanity-plugin-order-documents/build/components/OrderDocuments.js
 @ ./node_modules/sanity-plugin-order-documents/build/index.js
 @ ./node_modules/@sanity/vision/lib/VisionTool.js (all:part:@sanity/base/tool)
 @ ./node_modules/@sanity/default-layout/lib/util/getRegisteredTools.js
 @ ./node_modules/@sanity/default-layout/lib/router.js
 @ ./node_modules/@sanity/default-layout/lib/Root.js (part:@sanity/base/root)
 @ ./node_modules/@sanity/base/lib/components/SanityRoot.js (part:@sanity/base/sanity-root)
 @ ./node_modules/@sanity/server/lib/browser/entry-dev.js
 @ multi ./node_modules/@sanity/server/lib/browser/entry-dev.js
Nov 3, 2022, 9:59 PM
What version of the Studio are you running?
Nov 3, 2022, 10:04 PM
Hi
user M
! Here’s the output of `sanity versions`:
@sanity/cli                   2.35.0 (up to date)
@sanity/base                  2.33.3 (latest: 2.35.0)
@sanity/core                  2.35.0 (up to date)
@sanity/default-layout        2.33.3 (latest: 2.35.0)
@sanity/default-login         2.33.3 (latest: 2.35.0)
@sanity/desk-tool             2.33.3 (latest: 2.35.1)
@sanity/eslint-config-studio   2.0.0 (up to date)
@sanity/vision                2.33.3 (latest: 2.35.0)

Nov 3, 2022, 10:05 PM
Ah, yes, this was a bug in a previous version. Can you try upgrading your Studio? Please let me know if that doesn't fix it, though!
Nov 3, 2022, 10:11 PM
OK, will try that - thank you!
Nov 3, 2022, 10:12 PM
user M
that solved my issue, thanks again
Nov 3, 2022, 10:16 PM
Fantastic!
Nov 3, 2022, 10:19 PM
user M
We are running Studio v 2.33.3 with the Media Browser plugin and getting this same error. We had to remove the Media Browser to get the Studio to run again. At the moment we replaced the Media Browser with Media Library plugin.
Nov 23, 2022, 9:42 AM

Sanity– build remarkable experiences at scale

Sanity is a modern headless CMS that treats content as data to power your digital business. Free to get started, and pay-as-you-go on all plans.

Was this answer helpful?