🔮 Sanity Create is here. Writing is reinvented. Try now, no developer setup

Issue with installing `@sanity/vision` due to npm registry error.

10 replies
Last updated: Jul 14, 2023
Hey, I am having issues installing
@sanity/vision
. I get the following error. I am using NPM and have also tried yarn.
npm ERR! code E404
npm ERR! 404 Not Found - GET <https://registry.npmjs.org/@codemirror%2fcommands> - Not found
npm ERR! 404
npm ERR! 404  '@codemirror/commands@^6.0.1' is not in this registry.
npm ERR! 404
npm ERR! 404 Note that you can also install from a
npm ERR! 404 tarball, folder, http url, or git url.
Any help is greatly appreciated, thanks
Jul 14, 2023, 9:22 PM
Maybe npm registries are having issues, I just ran into a very similar issue recently: https://github.com/streetsidesoftware/cspell-dicts/issues/2331
Jul 14, 2023, 9:24 PM
So we just wait for it to be resolved?
Jul 14, 2023, 9:25 PM
Sorry, I just haven't come across this before
Jul 14, 2023, 9:25 PM
neither have i. i have no clue what's happening, my issue just looked exactly like yours
Jul 14, 2023, 9:26 PM
Oof
Jul 14, 2023, 9:26 PM
A second ago, https://registry.npmjs.org/@codemirror%2fcommands was 404ing. Now it's not. idk what changed
Jul 14, 2023, 9:26 PM
Jul 14, 2023, 9:27 PM
Well then... guess we just wait it out. Thanks sharing the link for the status page, forgot those exist
Jul 14, 2023, 9:28 PM
yeah me too. try installing again, mine just started working again
Jul 14, 2023, 9:28 PM
Nice, just worked
Jul 14, 2023, 9:31 PM

Sanity– build remarkable experiences at scale

Sanity is a modern headless CMS that treats content as data to power your digital business. Free to get started, and pay-as-you-go on all plans.

Was this answer helpful?