✨Discover storytelling in the AI age with Pixar's Matthew Luhn at Sanity Connect, May 8th—register now

Issue with installing Mux in a Sanity v2 project and resolving it by downgrading styled-components.

5 replies
Last updated: Feb 14, 2024
Has anyone successfully installed and using Mux in a project based on Sanity v2? I’ve tried to install it for over an hour now, and it won’t work..
Feb 13, 2024, 10:13 PM
Is there a chance you’re using the v3 install command instead of the v2?
Feb 14, 2024, 12:02 AM
No, I’ve been following the instructions on the Github page, but it’s giving me errors either on some styled components (which goes away if I remove the plugin) or it won’t find the v2-version
Feb 14, 2024, 9:22 AM
I installed the older version of styled-components in order to get the Mux plugin to work. (I’m on Sanity V3 though).
Feb 14, 2024, 1:43 PM
user C
Oh, that sounds like an option I need to try! What version of styled components did you downgrade to?
Feb 14, 2024, 2:16 PM
“styled-components”: “^5.2”
Worked for me! Hope that helps :)
Feb 14, 2024, 3:15 PM

Sanity– build remarkable experiences at scale

Sanity is a modern headless CMS that treats content as data to power your digital business. Free to get started, and pay-as-you-go on all plans.

Was this answer helpful?