👀 See Sanity in action: Watch product demo now →

Query for PDF not working - How to Query for a PDF

10 replies
Last updated: Jun 23, 2022
Hi there, I'm trying to query for a pdf that I've saved on sanity. It is of the type: "file". It currently looks like this when I print it:
PDF: { _type: 'file', asset: [Object] },

I want to access the object for its url so I can use it in an href like so:

<a href={pdf}/>

I tried like the docs suggest but it doesn't seem to work:

PDF{

asset->url

},
Jun 23, 2022, 2:57 PM
What doesn’t work? What data do you receive from your query? 🙂
Jun 23, 2022, 3:02 PM
It is a PDF file.
What doesn't seem to work is trying to unpack the object for its URL?
Jun 23, 2022, 3:04 PM
Hence why I ask what you get back from your query. Can you log it? 🙂
Jun 23, 2022, 3:05 PM
Yes, it looks like this:
PDF: { _type: 'file', asset: [Object] },
Jun 23, 2022, 3:06 PM
or otherwise this:
{

_type: 'file',

asset: {

_ref: 'file-f3654343bdaadea9dd8f256455b63afdc270637a-pdf',

_type: 'reference'

}

}
Jun 23, 2022, 3:06 PM
Right, to that means the asset hasn’t been resolved. Can you show the way you declare the field in your schema and your query itself?
Jun 23, 2022, 3:07 PM
Sure it looks like this:

{

name: "PDF",

title: "PDF",

type: "file",

description: "The pdf",

},
Jun 23, 2022, 3:08 PM
Alright, can you try this please?
"PDF": PDF.asset -> url
Jun 23, 2022, 3:09 PM
ahh voila! That worked. Thanks 🙂
Jun 23, 2022, 3:13 PM
Yay, amazing. 🙂
Jun 23, 2022, 3:14 PM

Sanity.io – build remarkable experiences at scale

Sanity is a customizable solution that treats content as data to power your digital business. Free to get started, and pay-as-you-go on all plans.