🔮 Sanity Create is here. Writing is reinvented. Try now, no developer setup

Trouble getting started with Sanity, unable to add new items to content type

18 replies
Last updated: Mar 16, 2021
Hi! I am trying to get started with Sanity for the first time, and haven't been able to get the studio to work yet. I did a clean install with the cli and used the "blog" schema template. I ran sanity start right away and everything seemed to spin up correctly. I was able to go to the desk at localhost:3333 but when I click on a content type, it just says "loading items" indefinitely and I am unable to add new items. I tried a clean install and then I tried another clean install without the blog schema template -- same thing each time. Does anyone else have any advice on this? I'm about ready to move on to a different CMS, which is too bad because Sanity seems cool 😞
Mar 16, 2021, 10:06 PM
Hi User. Sorry to hear there’s been some trouble getting started! Were there any error messages worth noting—either in the bottom-right corner or in your Developer Tools?
Mar 16, 2021, 10:29 PM
Nope! Nothing in chrome developer console or terminal
Mar 16, 2021, 10:33 PM
Would you be comfortable trying something in the terminal?
Mar 16, 2021, 10:51 PM
Yep!
Mar 16, 2021, 10:51 PM
If you go to your studio directory and run
sanity documents create
, you should get something like this:

{
  "_id": "c9d4c90b-c053-4e6b-8bd8-0d48a49cf7ac",
  "_type": "specify-me"
}
Set the
_type
to a document type that’s in your schema. Could be post, author, etc.
Mar 16, 2021, 10:53 PM
When you save the file, I’m curious to know if you get a “Created” response back with the
_id
.
Mar 16, 2021, 10:54 PM
Would that response come in the terminal window? Not seeing anything
Mar 16, 2021, 11:00 PM
Hang on, I had to close the text window. Got an id back
Mar 16, 2021, 11:01 PM
Yes, the response would normally come back in the terminal after having saved the file.
Mar 16, 2021, 11:01 PM
yep got an idea, had to close the file first
Mar 16, 2021, 11:02 PM
*id
Mar 16, 2021, 11:02 PM
Okay, that’s a good sign that you can interact via the CLI.
Could you try running
sanity logout && sanity login
, then
sanity start
again and see if that helps. I’m not confident it’ll solve the problem but at least we can tick it off.
Mar 16, 2021, 11:04 PM
aha!
Mar 16, 2021, 11:07 PM
That seems to have worked
Mar 16, 2021, 11:08 PM
Hey! Nice!
Mar 16, 2021, 11:08 PM
Thank you for helping out!
Mar 16, 2021, 11:08 PM
Strange though
Mar 16, 2021, 11:08 PM
Any time! Enjoy getting started and thanks for sticking it out. 🙂
Mar 16, 2021, 11:08 PM

Sanity– build remarkable experiences at scale

Sanity is a modern headless CMS that treats content as data to power your digital business. Free to get started, and pay-as-you-go on all plans.

Was this answer helpful?