🔮 Sanity Create is here. Writing is reinvented. Try now, no developer setup

Trouble setting up new site with create templates, errors encountered

9 replies
Last updated: May 23, 2020
I'm trying to set up a new site with the create templates. I've tried both the kitchen sink and the Gatsby blog but get errors every time I try to set it up. I don't get any error information; only that the build failed. See attached screenshot.
I simply filled out the forms on this page:
https://www.sanity.io/create?template=sanity-io%2Fsanity-template-gatsby-blog and it errorred. This has happened numerous times and I am unable to build any site.
Any help appreciated.
May 22, 2020, 8:25 PM
user B
Not sure if this is helpful, but I had this problem a few days ago—I ended up finding that there was a disparity between the Netlify account and my Github I was using—to be specific, I was trying to provision a repo and deploy from my personal GitHub, and had given access to my agencies Netlify instance to handle deployment, where my Github had never been authorized.
Not sure how/why this disparity contributed to the failed deployments, but going in to make sure I was properly authorized on both Github and Netlify in my browser fixed the issue for me.
May 22, 2020, 8:30 PM
As a side note, the portfolio setup is the first one that worked—curious if you would be able to deploy that one, or not
May 22, 2020, 8:31 PM
user P
I only have 1 account each for Sanity, github, & Netlify so I cant imagine that’d be it but then again I’m an amateur dev so I may have screwed up accounts. Worth investigating.
I was logged in to all accounts on the same browser window when I tried it.

I may have tried the portfolio starter before. I don’t recall. I am 99% sure I’d gotten the blog starter to work but (for some reason I don’t recall) I’d deleted it (probably was an early experiment as I tried to figure it all out so it was deleted to restart from scratch).

But I’ll try the portfolio starter again now.
May 22, 2020, 8:48 PM
In that case, I would double check that the sanity and netlify projects, as well as the github repo from previous deployments have all been deleted—may be a naming conflict, seeing something in one place or another and thinking "oh, hey, I already exist here" and failing
May 22, 2020, 8:51 PM
I do get a naming conflict error on the repo, even though I've double checked and verified the old repo was deleted and no other repo has that name.
This time, with the portfolio starter, I just ran with the default repo name. Everything worked.

Odd but at least I have something to start working on.

Greatly appreciate your help.
May 22, 2020, 8:55 PM
Ahh, interesting. Well, that's all I've got—good luck!
May 22, 2020, 8:57 PM
Like I said, your input helped. I have something to play with now! 🙂
May 22, 2020, 8:58 PM
Hi Rich, thanks for notifying. Not sure what this error is but we will look into it. It should not be naming error, that should be detected and get a specific message in the flow.
May 23, 2020, 3:43 AM
Hi again Rich, we think actually this one had to do with Gitub having some downtime, and also logs tells us that we did not manage to connect to github. Could you please try again, and let us now if it works?
May 23, 2020, 3:58 AM

Sanity– build remarkable experiences at scale

Sanity is a modern headless CMS that treats content as data to power your digital business. Free to get started, and pay-as-you-go on all plans.

Was this answer helpful?