🔮 Sanity Create is here. Writing is reinvented. Try now, no developer setup

Issue with deploying the kitchen sink demo on Netlify, but the problem has been resolved.

15 replies
Last updated: Dec 28, 2020
Just tried to deploy the kitchen sink demo twice...keeps failing. Any help?
Dec 28, 2020, 12:11 PM
privacy badger or something similar in your browsers?
Dec 28, 2020, 12:21 PM
i turned off adblockers and doing in incognito now. Trying entire thing from scratch again. Apologies. I'm like n00b level x10000
Dec 28, 2020, 12:23 PM
Could be a netlify problem, try another starter without netlify?
Dec 28, 2020, 12:35 PM
Log in to netlify and see if there are any errors on that side?
Dec 28, 2020, 12:36 PM
I posted the deploy error long thing.But i'm not sure how to deploy it without netlify. I'm just going through the sanity starter template thing
Dec 28, 2020, 12:38 PM
Thanks for reporting, Han! Looks like there might be another build in progress that this one is waiting for, or perhaps you've reached a build limit on your Netlify account?
If you go to your team overview on Netlify, you should be able to see
Build minutes used there. And if you enter the newly created project, it should show you its deployment status under the Deploys tab.
Dec 28, 2020, 12:38 PM
and i tried a different starter theme and that worked fine. hm maybe it's something to do with the kitchen sink one?
Dec 28, 2020, 12:38 PM
We'll investigate 🙂
Edit: I just confirmed one other case of the same error, so this might be an issue with the starter indeed. Will keep you posted.
Dec 28, 2020, 12:38 PM
im 52/300 build minutes. Thanks.And I just tried the "landing pages" started template and it worked fine.
But it seems to have built 2 of them at the same time:
sanity-nextjs-landing-pages-web-2mbh1js3
sanity-nextjs-landing-pages-studio-bxturs8h
Both say published

Idk why but the kitchen sink one keeps failing for me
Dec 28, 2020, 12:40 PM
thanks and apologies for the n00bness. I'm just an SEO content writer with only wordpress experience
Dec 28, 2020, 12:40 PM
I think you've uncovered an issue with the starter, so thanks for flagging! 🙂 I'll update here when it's confirmed fixed, so you can try the Kitchen Sink starter once more.
Dec 28, 2020, 12:42 PM
ok ill try again later. Thanks.Right now I'm knee deep in 8 different CMS's and trying to just learn. I will continue to explore!
Dec 28, 2020, 12:47 PM
[![Netlify Status](<https://api.netlify.com/api/v1/badges/98a73596-bd15-4010-87bc-1814d76b6e87/deploy-status)](https://app.netlify.com/sites/sanity-kitchen-sink-web-wfg6bwzb/deploys)>

Dec 28, 2020, 1:38 PM
Hi Han - this issue should now be resolved. The issue was having an outdated
gatsby
package with updated plugins that use the new
pluginOptionsSchema
API. The updated
gatsby
package now marks this as a known API, which should let deployments succeed. Sorry about the confusion 🙂
If you would like to continue working with one of your existing repositories, please run
npm update
in your
web
folder to get to
gatsby v2.29.2
.
Dec 28, 2020, 4:04 PM
Thank you!

please run 
npm update
 in your 
web
 folder
One day I will learn what this means. For now, I will just delete it and start over from scratch by remaking it lol
Dec 28, 2020, 4:46 PM

Sanity– build remarkable experiences at scale

Sanity is a modern headless CMS that treats content as data to power your digital business. Free to get started, and pay-as-you-go on all plans.

Was this answer helpful?