✨Discover storytelling in the AI age with Pixar's Matthew Luhn at Sanity Connect, May 8th—register now

Troubleshooting issues with Gatsby/Sanity blog starter

5 replies
Last updated: Jun 3, 2021
I’m working with the gatsby/sanity blog starter and I’m having a very confusing time. It all started last night when I tried to delete all the blog-post/unused components and am now unable to run the dev server, even after restoring those files. This is the log:
0 info it worked if it ends with ok

1 verbose cli [ '/usr/local/bin/node', '/usr/local/bin/npm', 'run', 'dev' ]

2 info using npm@6.14.8

3 info using node@v14.9.0

4 verbose run-script [ 'predev', 'dev', 'postdev' ]

5 info lifecycle sanity-gatsby-blog@1.0.17~predev: sanity-gatsby-blog@1.0.17

6 info lifecycle sanity-gatsby-blog@1.0.17~dev: sanity-gatsby-blog@1.0.17

7 verbose lifecycle sanity-gatsby-blog@1.0.17~dev: unsafe-perm in lifecycle true

8 verbose lifecycle sanity-gatsby-blog@1.0.17~dev: PATH: /usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/Users/tylerbrown/Documents/WebDevStuff/Orange Blossom Repo/orange-blossom-gatsby-site/node_modules/.bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin

9 verbose lifecycle sanity-gatsby-blog@1.0.17~dev: CWD: /Users/tylerbrown/Documents/WebDevStuff/Orange Blossom Repo/orange-blossom-gatsby-site

10 silly lifecycle sanity-gatsby-blog@1.0.17~dev: Args: [ '-c', 'lerna run dev --parallel' ]

11 silly lifecycle sanity-gatsby-blog@1.0.17~dev: Returned: code: 1  signal: null

12 info lifecycle sanity-gatsby-blog@1.0.17~dev: Failed to exec dev script
`13 verbose stack Error: sanity-gatsby-blog@1.0.17 dev: `lerna run dev --parallel``

13 verbose stack Exit status 1

13 verbose stack     at EventEmitter.<anonymous> (/usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:332:16)

13 verbose stack     at EventEmitter.emit (events.js:314:20)

13 verbose stack     at ChildProcess.<anonymous> (/usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:_55:14_)

13 verbose stack     at ChildProcess.emit (events.js:314:20)

13 verbose stack     at maybeClose (internal/child_process.js:1047:16)

13 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:287:5)

14 verbose pkgid sanity-gatsby-blog@1.0.17

15 verbose cwd /Users/tylerbrown/Documents/WebDevStuff/Orange Blossom Repo/orange-blossom-gatsby-site

16 verbose Darwin 20.4.0

17 verbose argv "/usr/local/bin/node" "/usr/local/bin/npm" "run" "dev"

18 verbose node v14.9.0

19 verbose npm  v6.14.8

20 error code ELIFECYCLE

21 error errno 1
`22 error sanity-gatsby-blog@1.0.17 dev: `lerna run dev --parallel``

22 error Exit status 1

23 error Failed at the sanity-gatsby-blog@1.0.17 dev script.

23 error This is probably not a problem with npm. There is likely additional logging output above.

24 verbose exit [ 1, true ]
Jun 3, 2021, 2:59 PM
Does
/Users/tylerbrown/Documents/WebDevStuff/Orange Blossom Repo/orange-blossom-gatsby-site
have a
package.json
with a “dev” script?
Jun 3, 2021, 3:19 PM
Actually I just figured it out, clearing the npm cache and deleting all node_modules, then re-starting the dev server did the trick.
Jun 3, 2021, 3:25 PM
Does
/Users/tylerbrown/Documents/WebDevStuff/Orange Blossom Repo/orange-blossom-gatsby-site
have a
package.json
with a “dev” script?
Jun 3, 2021, 3:19 PM
Thank you though, you guys are amazing.
Jun 3, 2021, 3:26 PM
Glad you got it sorted 😄
Jun 3, 2021, 3:26 PM

Sanity– build remarkable experiences at scale

Sanity is a modern headless CMS that treats content as data to power your digital business. Free to get started, and pay-as-you-go on all plans.

Was this answer helpful?